Mendix Cloud missing metrics in Frankfurt region

Incident Report for Mendix Technology

Resolved

Our teams have confirmed the fix is stable, and we are no longer observing any related anomalies in our logs.
New metrics are reporting correctly. We appreciate your patience and understanding throughout this incident.
Posted Sep 17, 2025 - 13:02 UTC

Monitoring

The fix for the container metrics gaps in the Frankfurt region (Kubernetes applications) has been released, and we are actively monitoring the system.
While new metrics are now reporting correctly, previously missing historical metrics are not yet restored. Our teams are currently investigating the possibility of recovering these missing metrics, and we will provide an update on this effort.
Posted Sep 17, 2025 - 12:38 UTC

Identified

Our teams are currently finalizing the fix and conducting tests. We anticipate releasing the resolution soon and will provide an update upon completion.
Posted Sep 17, 2025 - 11:13 UTC

Investigating

We are currently experiencing gaps in container metrics for the Frankfurt region, specifically affecting applications on our Kubernetes platform. The issue has been identified, and our teams are actively working on deploying a fix.
We will provide an update once resolved.
Posted Sep 17, 2025 - 09:10 UTC
This incident affected: Mendix Cloud Regions (Mendix Cloud EU (Frankfurt)) and Mendix Cloud Services (Logging, Monitoring, and Alerting).