We will be undergoing scheduled maintenance during this time.
Posted Jul 08, 2025 - 08:21 UTC
Scheduled
We will be releasing a hotfix of the Mendix Portal. During the update, you will still be able to use the Deployment features by going to https://cloud.home.mendix.com/
Posted Jul 08, 2025 - 17:00 UTC
This scheduled maintenance affected: Mendix Services (Mendix Portal).