Mendix Portal degraded performance

Incident Report for Mendix Technology

Resolved

We have not noticed any further issues on the Mendix Portal since our last update, and hence resolving this incident.
Posted Sep 17, 2025 - 09:19 UTC

Monitoring

We restarted Mendix Portal and it's stable now. We'll continue monitoring it's performance.
Posted Sep 16, 2025 - 13:02 UTC

Investigating

Mendix portal is experiencing intermittent slowness and inaccessibility. We are investigating the issue.
Posted Sep 16, 2025 - 09:39 UTC
This incident affected: Mendix Services (Mendix Portal).