Resolved
Our clusters continue to operate without any disruption after the hotfix was applied.
Posted May 08, 2026 - 16:03 UTC
Monitoring
We have applied a security hotfix to our infrastructure in all Mendix Cloud regions. We continue to monitor the systems.
Posted May 08, 2026 - 15:53 UTC
Investigating
We will be applying a security hotfix to our infrastructure across all Mendix Cloud regions this afternoon. No application restarts are required and no customer impact is expected.
Posted May 08, 2026 - 12:52 UTC
This incident affected: Mendix Cloud Regions (Mendix Cloud US-East, Mendix Cloud EU (Frankfurt), Mendix Cloud Asia Pacific (Tokyo), Mendix Cloud Free Tier EU, Mendix Cloud UK, Mendix Cloud IE, Mendix Cloud US-West, Mendix Cloud Asia Pacific (Sydney), Mendix Cloud Canada (Central), Mendix Cloud Asia Pacific (Singapore), Mendix Cloud Asia Pacific (Mumbai), Mendix Cloud Middle East (Bahrain), Mendix Cloud Africa (Cape Town), Mendix Cloud Middle East (UAE), Mendix Cloud South America (São Paulo), Mendix Cloud EU (Frankfurt 2), Mendix Cloud Asia Pacific (Osaka), Mendix Cloud Asia Pacific (Seoul), Mendix Cloud Asia Pacific (Jakarta), Mendix Cloud EU (Frankfurt): GenAI Resources, Mendix Cloud Canada (Central): GenAI Resources) and Mendix Cloud Dedicated Regions (Mendix Cloud Dedicated EU (Frankfurt) Alfa, Mendix Cloud Dedicated US-West Alfa, Mendix Cloud Dedicated US-West Echo, Mendix Cloud Dedicated UK Echo, Mendix Cloud Dedicated Asia Pacific (Singapore) Echo, Mendix Cloud Dedicated US-East Hotel, Mendix Cloud Dedicated US-East Mike, Mendix Cloud Dedicated US-East Papa, Mendix Cloud Dedicated EU (Frankfurt) Sierra, Mendix Cloud Dedicated EU (Frankfurt) Uniform, Mendix Cloud Dedicated Asia Pacific (Singapore) Able, Mendix Cloud Dedicated US-East Kilo, Mendix Cloud Dedicated US-East Charlie, Mendix Cloud Dedicated US-East Colin, Mendix Cloud Dedicated EU (Frankfurt) Metro).