A fix has been implemented and we are monitoring the results.
Customers are free to deploy (for the first time), perform downsizes, or clear databases again.
Posted Jul 17, 2026 - 09:28 UTC
Update
We are continuing to work on a fix for this issue.
This incident will be updated in 24 hours, or as events warrant.
Posted Jul 13, 2026 - 12:32 UTC
Identified
We are facing issues with database provisioning in the Mendix Cloud UK cluster. Customers will experience issues while creating new apps but existing apps will work fine.
Issue is related to our cloud provider not having capacity on one of the availability zones.
Please do not deploy new applications if you are deploying for the first time, perform downsizes, or clear database during the incident.
Posted Jul 06, 2026 - 12:03 UTC
This incident affected: Mendix Cloud Regions (Mendix Cloud UK).